IDE 플러그인, .exe 다운로드 차단으로 인해 Windows 시스템에서 스캔 실패

문제점

Windows 시스템에서 IDE의 Snyk 플러그인을 사용할 때 Snyk 스캔이 실패할 수 있습니다.

Error running command snyk.start: command 'snyk.workspace.scan' not found. This is likely caused by the extension that contributes snyk.start.와 같은 오류 메시지가 로그에 나타날 수 있습니다.

원인

이 문제는 대개 Windows 시스템에서 회사 정책이 방화벽 또는 다른 도구에서 .exe 파일의 자동 다운로드를 방지하기 위해 승인을 요청하는 대화형 팝업을 표시하여 발생하는 경우가 많습니다.

이 팝업은 IDE에 표시되지 않으며 .exe 파일을 다운로드할 수 없습니다. 이로 인해 다운로드 위치에 0KB 파일이 생성될 수 있습니다.

이것이 문제인지 확인하려면 IDE의 Snyk 플러그인 설정에 표시된 CLI 또는 언어 서버 위치로 이동하십시오. CLI 또는 언어 서버 파일 중 하나가 0KB인 경우 이것이 문제일 가능성이 높습니다.

해결책

이에 대한 선호되는 해결책은 .exe 파일에 대한 기준 정책에서 downloads.snyk.iostatic.snyk.io를 허용 목록에 추가하여 이 위치에서 다운로드하는 파일이 모든 사용자에 대해 .exe 팝업 승인에서 제외되도록 하는 것입니다.

선호되는 해결책을 승인하는 데 시간이 걸릴 경우 임시로 다음 해결책을 사용할 수 있습니다.

또는

  • CLI exe가 다운로드된 경우 이를 사용하여 언어 서버 기능을 제공할 수 있습니다. 플러그인 설정에서 언어 서버 위치를 CLI 위치로 리디렉션하고 종속성 자동 관리 옵션을 끄십시오.

Last updated